Back to overview
Downtime

Elevated timeouts

Oct 29 at 02:17pm PDT
Affected services
api.firecrawl.dev

Resolved
Oct 29 at 04:48pm PDT

Customers who were exceeding their concurrency limit during this outage may be encountering strange errors in their crawls.

This is due to the nature of the outage affecting our concurrency limiting system, causing unique jobs to be inserted into a separate per-team concurrency queue multiple times. When these jobs are promoted from the concurrency queue into the main queue, they retain their IDs, which causes a violation of the unique ID constraint.

A fix for this issue is now deployed.

Updated
Oct 29 at 02:29pm PDT

The issue is resolved. Thank you for your patience.

Created
Oct 29 at 02:17pm PDT

We are experiencing elevated timeouts. We are currently investigating.