Back to overview
Degraded
Some requests are not completing
Apr 19, 2026 at 7:35pm UTC
Affected services
api.firecrawl.dev
Resolved
Apr 19, 2026 at 8:07pm UTC
Everything should be working now. We are still monitoring it.
Affected services
Updated
Apr 19, 2026 at 7:58pm UTC
Requests are failing again. Our upstream provider GCS is facing issues right now. We are working on it.
Affected services
Updated
Apr 19, 2026 at 7:44pm UTC
We were made aware of a potential security breach at Vercel via their public channels, and out of an abundance of caution we are rotating some keys on our end. Most things are back up now. Will keep you updated
Affected services
Created
Apr 19, 2026 at 7:35pm UTC
We are investigating.
Affected services